Back to overview
Downtime

Website currently unavailable

Jun 12 at 08:24pm BST
Affected services
Provisioning and Data Server

Resolved
Jun 12 at 09:06pm BST

All services are back online. Thank you for your patience. We will be working with our external partners to prevent similar issues from happening again.

Updated
Jun 12 at 09:05pm BST

Some errors are still popping up, but we’re seeing slow, steady improvement. Things aren’t back to normal yet, so we’re keeping a close watch and will update you as soon as we know more from Cloudflare and our external providers.

Updated
Jun 12 at 08:41pm BST

We have identified the root cause of the incident and our supplier is working hard to resolve the issue as soon as possible. Root cause: a global Cloudflare outage is intermittently blocking traffic to our API and database layer.
(See Cloudflare’s own incident report: “Broad Cloudflare service outages,” incident ID 25r9t0vz99rp.)

Created
Jun 12 at 08:24pm BST

All services are currently unavailable. This is due to an issue with Cloudflare, our external provider. We hope to restore full service soon. We are available to deal with all queries via email.